首页 > 编程学习 > macOS 下JD-GUI报JDK1.8+的问题

macOS 下JD-GUI报JDK1.8+的问题

发布时间:2022/11/7 1:49:02

问题来源

ERROR launching 'JD-GUI'

No suitable Java version found on your system!
This program requires Java 1.8+
Make sure you install the required Java version.

如图

 实际上是sh脚本获取的jdk的版本不对

解决如下

先看jdk的版本

然后

 

 打开脚本

脚本如下

 

 这里不就是jvm的版本不对,那么设置版本号即可,也可以写的灵活一点,执行java -version

然后取第一行第3列的值

注意=号两边不能有空格,shell基本常识

 

 结果

 

Copyright © 2010-2022 dgrt.cn 版权所有 |关于我们| 联系方式