首页 > 编程学习 > 思科与华为BGP配置命令对比

思科与华为BGP配置命令对比

发布时间:2022/11/12 9:06:34

思科与华为BGP配置命令对比
Cisco(config)#router bgp 100 //配置BGP进程号
[Huawei]bgp 100 //启动BGP,指定本地AS编号,并进入BGP视图
Cisco(config-router)#bgp router-id 1.1.1.1 //配置BGP的router-id
[Huawei-bgp]router-id 1.1.1.1 //配置BGP的Router ID
Cisco(config-router)#neighbor 12.1.1.2 remote-as 200 //配置BGP邻居
[Huawei-bgp]peer 2.2.2.2 as-number 100 //创建BGP对等体
Cisco(config-router)#neighbor 2.2.2.2 update-source loopback 0 //指定BGP的更新源
[Huawei-bgp]peer 2.2.2.2 connect-interface GigabitEthernet 0/0/1 //指定BGP对等体之间建立TCP连接会话的源接
Cisco(config-router)#neighbor 2.2.2.2 ebgp-multihop 2 //配置EBGP跳数为2
[Huawei-bgp]peer 3.3.3.3 ebgp-max-hop 1 //指定建立EBGP连接允许的最大跳数,缺省为1,即只能在物理直连链路上建立EBGP连接
Cisco(config-router)#neighbor a1 peer-group //定义peer-group
[Huawei-bgp]group a1 //创建对等体组
Cisco(config-router)#neighbor a1 remote-as 200
[Huawei-bgp]peer a2 as-number 200 //配置EBGP对等体组的AS号
Cisco(config-router)#neighbor 12.1.1.2 peer-group a1 //引用peer-group
[Huawei-bgp]peer 1.1.1.1 group a1 //向对等体组中加入对等体
Cisco(config-router)#neighbor a1 update-source loopback 0
[Huawei-bgp]peer a2 connect-interface GigabitEthernet 0/0/1 //指定BGP对等体之间建立TCP连接会话的源接口和源地址,缺省使用报文的出接口作为BGP报文的源接口
Cisco(config-router)#redistribute ospf 1 match internal external //将OSPF的内部和外出路由都重发布到BGP
[Huawei-bgp]ipv4-family unicast //进入IPv4地址族视图
[Huawei-bgp-af-ipv4]import-route ospf 1 //配置BGP引入其他协议的路由
Cisco(config-router)#network 12.1.1.0 mask 255.255.255.0 //宣告有类网络
[Huawei-bgp-af-ipv4]network 10.1.1.1 //配置BGP逐条引入路由表中的路由
Cisco#show ip bgp neighbors //查看BGP邻居
[Huawei]display bgp peer //查看所有BGP对等体的信息
Cisco#show ip bgp neighbors 12.1.1.2 received-routes //从邻居接收到的BGP路由条目
Cisco#show ip bgp neighbors 12.1.1.2 routes //查看从邻居学到的BGP路由
Cisco#show ip bgp neighbors 12.1.1.2 advertised-routes //查看发送给邻居的BGP路由条目
[Huawei]display bgp peer 10.1.1.1 verbose //查看指定BGP对等体的信息
Cisco#show ip bgp //查看BGP表
[Huawei]display bgp routing-table //查看BGP路由的信息
[Huawei]display bgp group //查看对等体组信息
Cisco(config-router)#neighbor 12.1.1.2 password abc123 //配置BGP认证,只支持MD5认证
[Huawei-bgp]peer 2.2.2.2 password cipher abc123 //配置MD5认证密码
Cisco#show ip bgp summary //查看BGP邻居摘要信息
[Huawei]display bgp peer verbose //查看BGP对等体的认证详细信息
Cisco(config-router)#neighbor 12.1.1.2 route-reflector-client //配置路由反射器的客户端
[Huawei-bgp-af-ipv4]peer 2.2.2.2 reflect-client //置路由反射器及其客户
Cisco(config-router)#bgp cluster-id 1.1.1.1 //修改放射器的簇ID
[Huawei-bgp-af-ipv4]reflector cluster-id 1.1.1.1 //配置路由反射器的集群ID,缺省每个路由反射器使用自己的Router ID作为集群ID
Cisco(config-router)#bgp confederation identifier 123 //标识BGP联邦号
[Huawei-bgp]confederation id 1 //配置联盟ID,缺省未配置
Cisco(config-router)#bgp confederation peers 234 //配联邦EBGP号
[Huawei-bgp]confederation peer-as 1 //指定属于同一个联盟的子AS号
Cisco(config-router)#neighbor 12.1.1.2 filter-list 1 in //关联as-path访问控制列表到filter-list进行路由过滤
[Huawei-bgp-af-ipv4]peer 2.2.2.2 filter-policy 2000 export //基于访问控制列表ACL配置对特定对等体(组)发布的路由信息进行过滤
Cisco(config-router)#network 11.11.11.0 mask 255.255.255.0 route-map rm1 //给所有邻居在network时关联执行路由策略
[Huawei-bgp-af-ipv4]peer 2.2.2.2 route-policy a1 export //基于Route-Policy配置对特定对等体(组)发布的路由信息进行过滤
Cisco(config-router)#neighbor 12.1.1.2 route-map rm1 out //给特定邻居执行路由策略
[Huawei-bgp-af-ipv4]peer 2.2.2.2 route-policy a1 import //基于Route-Policy配置从特定对等体(组)接收路由
Cisco#show ip as-path-access-list //查看as-path访问控制列表的配置
[Huawei]display ip as-path-filter //查看已配置的AS路径过滤器信息
Cisco#show ip bgp regexp xx //查看BGP表中被正则表达式匹配上的路由
[Huawei]display bgp multicast routing-table regular-expression a1 //查看匹配AS正则表达式的MBGP路由信息
Cisco(config-router)#auto-summary //打开自动汇总
[Huawei-bgp-af-ipv4]summary automatic //自动配置按照自然网段聚合子网路由
Cisco(config-router)#aggregate-address 172.16.0.0 255.255.0.0 //配置BGP的路由聚合,通告汇总和明细路由
Cisco(config-router)#aggregate-address 172.16.0.0 255.255.0.0 summary-only //配置BGP的路由聚合,只通告汇总路由,抑制明细路由
[Huawei-bgp-af-ipv4]aggregate 10.1.1.1 16 //手动发布所有聚合路由和被聚合的路由
Cisco(config-router)# aggregate-address 172.16.0.0 255.255.0.0 summary-only as-set //配置BGP的路由聚合,只通告汇总路由,抑制明细路由,且继承原有明细路由的AS属性
[Huawei-bgp-af-ipv4]aggregate 10.1.1.1 16 detail-suppressed //只手动发布聚合路由
[Huawei-bgp-af-ipv4]aggregate 10.1.1.1 16 suppress-policy a1 //只手工发布聚合路由和通过路由策略的被聚合的路由
[Huawei-bgp-af-ipv4]aggregate 10.1.1.1 16 as-set //只手工发布检测环路的聚合路由
Cisco(config-router)#aggregate-address 172.16.0.0 255.255.0.0 summary-only as-set attribute-map rm2 //在BGP路由汇总时直接设置路径属性
[Huawei-bgp-af-ipv4]aggregate 10.1.1.1 16 attribute-policy a1 //手工设置聚合路由的属性
[Huawei-bgp-af-ipv4]aggregate 10.1.1.1 16 origin-policy a1 //只手工将通过路由策略的路由生成聚合路由
Cisco#clear ip bgp * //硬重置所有邻居
reset bgp all //复位BGP连接, 会导致交换机之间的BGP Peer关系中断
Cisco#clear ip bgp 12.1.1.2 //硬重置单个邻居
reset bgp 2.2.2.2 //复位与指定对等体的BGP连接

Copyright © 2010-2022 dgrt.cn 版权所有 |关于我们| 联系方式